Critical WordPress Plugin Vulnerability – BeaverBuilder and Elementor Affected

Reading Time: 3 minutes Are you a WordPress user who has “Ultimate Addons for Beaver Builder” or “Ultimate Addons for Elementor” Installed? If you have not updated since Wednesday, December 11th 2019, chances are … Read More

US Postal Service Addresses Vulnerability That Exposed 60 Million Users Data For Over A Year

Reading Time: 3 minutes A critical security vulnerability that exposed the data of more than 60 Million customers to anyone who has an account to USPS.com was finally patched this last week. The vulnerability … Read More